Documentation

NEW DOCUMENTATION: I’m currently building a whole new documentation for Painting With Light.  Once all the information from these pages has been copied over I’ll automatically redirect this page but for now, you can access it at:

Painting With Light Wiki Documentation

Old Documentation

Painting With Light is an easy to use software application developed by artist Alex May that aims to provide artists with a real-time, hands-on approach to video mapping.

Painting With Light Overview

The Main Concept

Painting With Light works like a paint program, along the lines of Adobe Photoshop, Paint.NET, GIMP and many others, but it differs in two important ways:

1. It is designed to be used with a video projector – to paint light onto real physical objects

2. You can paint with multiple video and other animated elements

Traditionally, video mapping is a complex procedure that requires a high level of technical knowledge and often prohibitive costs for software and hardware.  This software allows you to try video mapping in a very hands on way, and is specifically aimed at enabling artists to experiment with the medium and try out different approaches.

Quick Start Information

To try the software out, you can use Painting With Light on a single screen, without a video projector.

You can draw on the Output Window or the Work Area but it is recommended to get used to working on the Work Area as when you are outputting to a video projector, it will save you moving your mouse to the other screen.

By default, the Work Area does not draw the painting (it only appears in the Output Window).  You can change this by selecting Edit Menu -> Options… -> Rendering -> Render to Work Area and then restarting the application.

The main window interface is made up of smaller windows that control different aspects of the software.  These windows can be opened and closed from the Windows Menu.

You can close the individual windows or drag them around and place them inside the main window to customise the interface to your own personal preference.

The functionality of each window is relatively simple but they often combine resulting in complex behaviours.  Take time to experiment with the functions of each one.

There are four types of tools and controls on the Toolbar:

Painting With Light Toolbar

  1. Hand drawing tools
    1. Brush
    2. Roller
  2. Editable tools
    1. Quad
    2. Polygon
    3. Lines
    4. Path
    5. Loop
    6. Rays
    7. Bezier (1.0.3+)
  3. Editable Tools Control
    1. Tick
    2. Cross
  4. Colours
    1. Foreground Colour
    2. Background Colour (default is black)

IMPORTANT: when using the editable tools, you must get into the habit of clicking on the Tick or Cross on the Toolbar when you have finished editing.  Clicking the Cross will delete the shape you are drawing.

Once something is drawn using the hand drawing tools, or an editable tool is accepted, you cannot edit it again.  However, you can undo many previous actions (from the Edit Menu or Undo Window).

When drawing with any tool, it will comprise of a colour (white is default), an optional brush, and an optional texture (either a picture, video clip, or gradient)

What Each Window Does

Brushes

  • Click on a thumbnail to select a brush
  • Click Load to select PNG images to use as a brush
  • Clicking Remove will unload the selected brush
  • Clicking Clear will deselect the current brush

Colour

  • Selects the colour to draw with
  • Provides a set of complimentary colours based on simple colour theory

Colour Box

  • Click anywhere in the box to select a colour

Colour Wheel

  • Click anywhere in the wheel to select a colour

Gradients

  • Define colour gradients

Layers

  • Separate painting into layers
  • The main use being to mask out areas for drawing

Mapping

  • Control how the texture (picture, video, or gradient) is applied to your current tool
  • Changing the Cycle Speed will allow you to draw with a animated brush
  • Clicking the Reset button will set the default values

Presets

  • When you have a tool configuration you like, enter a name in the top box and click the Save button to store that set up
  • Double-clicking on the list of presets will load the selected tool configuration

Stroke

  • Only useful for the hand drawing tools
  • Controls how the line is drawn
  • Can add randomisation
  • Can add pressure information from a graphics tablet to control each parameter
  • Clicking the Reset button will set the default values

Textures

  • Loads pictures and video clips

Undo

  • Shows the current Undo list
  • You can adjust how many steps are stored in the list by going to Edit Menu -> Options… -> General -> Undo Steps

Other Important Things

You can clear your current painting using File Menu -> New

You can save your painting using File Menu -> Save Painting As…

You can load your painting using File Menu -> Load Painting…

You can save an image of your painting using File Menu -> Save Image…

You can make the Output Window go full screen (or stop being full screen) by pressing your Alt + Enter keys or using Output Menu -> Full Screen

Detailed Documentation

Leave a Reply